VMware Hypervisor Free?

#1

Anyone played with the ‘free’ license for VMWare Hypervisor as a way to learn more about the tech? I’ve been considering trying it out for something, but wondering if I’m crazy.
This is not, of course, an either/or situation.

1 Like

#2

Definitely. My home server was running that for a few years (until the humidity in the garage finally killed it).

If you want to learn VMware though you’ll need to aim for vSphere - lots more magic in there. You can do some really cool stuff, like vMotion (migrate from one host to another with no downtime), Storage vMotion (migrate virtual disks from one datastore to another, with no downtime), automatic load balancing, Virtual SAN… whew.

Last time I did a VCP (5 years ago) there were trial/study versions of most products available for download - not sure about these days though.

0 Likes

#3

Is there a free/limited vSphere for educational purposes?

I’m doing the crazy thing and running it on a Mac Mini I have doing nothing, but it’ll probably only run 2-4 VMs for stuff I need local, plus maybe some interesting stuff.

I’m working with the tech more at work as I’m apparently the expert (scary title…) at dealing with the Cisco UCS modules we have scattered around the company… which are running servers bare metal. We have a dedicated Compute team that specializes, but being able to talk to them coherently never hurts.

I figure if I get the bare server up I’ll load it up with:

  • Image running the Unifi controller (Thanks, @Lee_Ars I’m buying ubiquiti gear now)
  • Maybe Plex as a front-end to my existing NAS which can’t easily run Plex
  • If I go insane, maybe back to MInecraft, not that I have time.
  • Maybe try moving a VMWare Fusion image I run on my Macs of MacOS X 10.6 I keep around to run an old version of Adobe CS4 for file migration purposes.
  • Maybe an LDAP server.

Mostly learning, but some stuff in the ‘nice to have’ category. Keeping the NAS independent as that’s “home production” and not something I want unstable.

0 Likes

#4

@balance, if you’re interested in a bit of a course change, you might look into LXD/LXC. That’s what I’m using to virtualize everything here.

LXC == “linux containers.” Think of it as a lightweight virtual machine without a kernel—it does everything a virtual machine does, but it uses the host’s kernel instead of having its own. You get bare metal speeds for most things, and it looks and acts like a regular VM. There are some circumstances where a full VM is appropriate, but for most hosting situations, an LXC container is perfect.

Going by your list, for example—I use LXC containers on a single server to host my unifi controller, my Plex server, and a local Minecraft server. Along with a whole bunch of other stuff:

LXC guests are in the big bubble call-out at the bottom.

“LXD” is an LXC daemon manager & front-end for Ubuntu Server. It makes creating & managing LXC containers easier and gives you some more options for what kinds of containers you can create. It also automates a lot of the process of actually creating the things.

Stéphane Graber has a great series of blog posts to intro you & get you started with LXD, assuming you’re interested in running linux on your server. Personally, LXD/LXC has been a huge time-saver for me and I really like using nice, containerized little VMs for tasks:

2 Likes

#5

Unfortunately if you want to cluster vmware (or use the other cool features) you’ll either have to procure a licence, or you’ll have to do a perpetual reinstall (back up your VM’s, reinstall, restore VM’s) and use the clustering etc during the trial period.

Or look at proxmox or any other free hypervisor that’ll allow you to do what you want without restrictions.

0 Likes

#6

Thanks. I might check that out as it looks like I wouldn’t be getting a lot of transferable experience with th3 free tier hypervisor anyway.

0 Likes

#7

Hm. Got the ‘basics’ lf LXD set up this weekend. The main issue now is getting networking set up…

0 Likes

#8

Just jumping in to let you now you can get a VMUG Advantage license if you want to explore the full breadth of VMware in a homelab!

Last time I checked it was around $200-300 a year for a license. It includes a lot of stuff but the part you’ll be interested in is the Eval Experience which gives you a valid license to use all the core stuff for a full year in a non-production environment.

1 Like

#9

LXD/LXC has some definite advantages here, as most of the Cisco gear I touch these days runs Cisco IOS-XE… Which supports LXC, apparently.

0 Likes

#10

@mikhail, this is good info! Might need to do it myself when it comes to (re-)getting my VCP.

0 Likes

#11

@Lee_Ars, any idea how to set up networking to just pass-through? I.E. so my LXC containers get DHCP from the same source as the host box and are on the same subnet?

Seems liek ti should be simple but it isn’t.

0 Likes

#12

I believe you need to have a bridged adapter available on your host for that to work. I set it up a couple of years ago and it’s been working since, and I’m honestly not sure exactly what I did (I think it was part of the initial LXD config wizard).

This oughta get you there—the instructions in there look pretty familiar.

0 Likes

#13

+1 for containers. I’ve been using them more and more at work and at home. I’ve thought of switching my pi-hole to a container here at home, but it seems silly to have a dedicated full sized machine to run something that’s running on a Pi right now. My containers are just Docker right now but I’m drifting into LXD/LXC.

As for vCenter/vSphere, the problem is getting the software. Once you do, you have 180 days of a ‘trial’. This is the same for the hypervisor. A new install has all the shiny things in it like PowerCLI access. After 180 days it reverts to a dumb system but it is still useful. I had a full lab on my server a couple years ago.

1 Like

#14

Got some time to play with this today since I worked from home… Amazing what not having to commute will do for your day!

The frustration is I, of course, picked a version of Ubunto (18.04 LTS?) where they decided to Try Something New! with predictable results. In this case it’s something called “netplan” which is apparently either amazing or horrible depending on who you talk to.

So, today, I have:

  • Reinstalled the OS twice.
  • Tried multiple config options.

It’s kind of odd. Some commands seems to think there’s an existing bro interface even when there isn’t one.

So I get a file like this:

network:
renderer: networkd
ethernets:
enp1s0f0:
addresses:
- 192.168.1.200/24
dhcp4: false
gateway4: 192.168.1.1
nameservers:
addresses:
- 8.8.8.8
- 8.8.4.4
search: []
version: 2

(that’s mostly from my static IP assignments.)
And it looks like I should just need to add something like:

bridges:
br0:
interfaces: [enp1s0f0]
dhcp4: true

Doing so, however totally kills networking for the system. Drops SSH, so I have to switch to a console connection and remove it and do netplan generate; netplan apply to fix it.

Off to dig around more…

0 Likes

#15

Try Linux Mint? It is based on Ubuntu.

0 Likes

#16

Ohhh yeah, netplan. AKA “The thing that made me give up, destroy the 18.04 container I’d been playing with, and just stick with 16.04” :frowning:

0 Likes

#17

I may have to change to a different distro. Maybe this weekend if it’s quiet. It’s not like I’m attached to any of them really.

0 Likes

#18

Trying out Veeam Backup and Replication between two ESXi hosts. So far so good, but it is manual replication, good enough for transferring a host or two over.

Not sure if the free version of Veeam B&R can do replication, or whether you need to register it in order to do replication after the free trial ends.

Going to look at vSphere next (if I can get it up and running… previous tries were all fails).

0 Likes

#19

meh
testing on a 100-base LAN is ******

gonna put an order in for a small 10Gig switch for the lab network.

1 Like