Outage since last night was my fault, derp


#21

Did that at both work and home and still have the same issue. Maybe its a firefox thing?


#22

I’m using Firefox at work.


#23

I did Shift+refresh on my system at home, closed the browser and accessed the site again. Seems to be working properly now.


#24

I tried that to no avail. :thinking:


#25

Huh. Interesting. All right, I’ve made one reversion—if you guys wouldn’t mind poking at it a bit more over the next day, that’d be helpful. I can’t duplicate any weirdness here, but we all know “it works on my computer!” is no excuse :slight_smile:


#26

It loaded normally for me this morning.


#27

At least you’re probably not responsible for the current massive CenturyLink outage…


#28

It worked this morning just fine!


#29

I’d be lying if I said I knew why the thing I changed made a difference (I’d moved http -> https redirects down the stack, letting nginx do them instead of haproxy, and that’s what I just reverted), but who the hell even knows with these computer things.


#30

The problem is back today.


#31

Can you help me understand a little bit more specifically about what you’re seeing? Is it with the chroniclesofgeorge main site, or the forums here? Are you accessing the site by typing into the URL bar, or by a bookmark? Which URL specifically are you using?

Trying to figure out how to reproduce the issue—not able to get anything other than very fast load times both direct and also VPN’d into work and running from a remote system there. Google’s pagespeed measurement for the CoG main site shows pretty quick loads (image).

I’d be especially interested to know if you’re navigating to chroniclesofgeorge.com or www.chroniclesofgeorge.com. I’v got a 301 redirect in place on the former, because I want www there for pedantic cranky sysadmin reasons; it shouldn’t add more than a few milliseconds to page loads, but perhaps it’s misbehaving?

Here’s the page loading in Chrome’s dev tools if I leave out the www—note the initial non-www -> www 301 redirect:

The redirect adds about 200-300ms to the page load. (I get roughly similar results through the work VPN).

If you get to a point where you can repeatedly recreate the issue, can you look at the “network” tab in your Chrome or Safari or Firefox web tools and see if there’s any obvious hang-up?

Anything helps! Would really love to figure out what this is so I can fix it once and for all.


#32

You know, I wonder if this isn’t all DNS-related?

@Nabiki, if you’re on a mac or linux box, would you post the output of these two commands?

dig chroniclesofgeorge.com |grep -i 'Query time'
dig www.chroniclesofgeorge.com |grep -i 'Query time'

Run 'em each a few times—the first time you run one, it might take as long as 200ms to resolve, but subsequent runs should return a much lower time as your system should cache the response.

If you get timeouts or long delays here, that’s definitely indicative of some kind of funky dns issue.

If you do get timeouts or slow responses here, you can try directing the DNS queries to different resolvers to see if the results change:

dig @9.9.9.9 www.chroniclesofgeorge.com |grep -i 'Query time'
dig @8.8.8.8 www.chroniclesofgeorge.com |grep -i 'Query time'
dig @209.244.0.3 www.chroniclesofgeorge.com |grep -i 'Query time'

You can use any resolver you have access to.

(If you’re on Windows, then never mind—I’m sure there’s a way to do this but windows is dumb and I don’t use it for real work anymore so i have no idea what the dig equivalent is on windows these days :frowning: )


#33

Unfortunately, I am using a Windows box. It didn’t happen today, but when I do have the issue, I am using a bookmark, and it takes a while to load, but loads a completely blank page. I refresh the page, and it works normally.
My DNS points towards Google’s DNS (8.8.8.8) since Comcast’s DNS generally sucks.

This is my bookmark
Chronicles of George Forum


#34

You can install dig on windows. It’s a pain to do so, but it’s possible.


#35

Earlier today CoG was totally unresponsive when I opened it on my android device.

Haven’t got access to a Linux box atm, but will make a plan. Maybe I have an ISO somewhere and can run a linux VM and do a bit of digging as per the above.


#36

Same link I use from my iPad and Mac mini. No issues today or since you first reported this problem.


#37

So just to be clear, @Nabiki and @ook, so i know where to look—you guys are specifically talking about this forum, right? That would make sense—there are a lot of moving parts there to get screwed up.


#38

Yes, the forum specifically. :slight_smile:
Happy New Year!


#39

HAPPY NEW YEAR TOO!!!

Lemme get my Wrench of Smiting and see what this crazy discourse thing is up to…


#40

Yep.

Am going to office tomorrow, will run a few tests from a linux box there, and let you know.

Cheers!