Install Linux Mint/FreeBSD/whatever on a Linkbook

Hey guys

I need the assistance of a Linux guru here.

Basically what I want to do, is to replace the preinstalled OS on my Linkbook with a newer Linux distro.

However, there is no way of getting into the BIOS at this stage. Unless somebody have a way of identifying the BIOS and its hotkey at boot, I’m stuck with trying to install a newer OS while the linkbook OS is running, kinda like an in-situ upgrade.

And I’m not sure whether it is possible.

So, let the games begin.

My ultimate aim is to use this linkbook as a firewall/content filter with logging done to USB memory stick to save wear and tear on the internal storage.

Cheers

Ook

Everything at this link says it’s not possible.

Datajack posted a way in that link, but it looks like something I wouldn’t want to try…

For the linux guru’s who whish to install other applicatins and / or
possibly installing another Linux on the LInkbook: press the “u” key
reapeadidly just after powering on, this will take you to a recovery
console. BEWARE: recovering will cause data loss. Backup data first.
When prompted with “menu system resume”, press “ctrl” and “c” together
on the keyboard. The you will be dropped into a shell. mount the
filesystem and edit some files: first, create mount point: mkdir
/mnt/hda, then mount /dev/hda1 /mnt/hda, now, edit the password file: vi
/mnt/hda/etc/passwd, add a new line, it should look something like
this:

user2:x:0:0:user2,:/root:/bin/bash

edit the line starting with “gdm:106:107:…” and ending with “:/bin/false”

change the 16 and 107 both to 0, and the end of the line to /bin/bash"

now go on to editing the /etc/shadow file, add a new line starting with “user2:”

now copy everything after the “user:” line somewhere higher up in this
file, and paste it after the new “user2:” piece which was added to the
bottom of the file.

one more thing, to prevent it from booting into the crappy resticted GUI: edit

the /etc/passwd file, edit the line starting with “gdm:106:107:…”

change it ti “gdm:0:0:…” when booting up, it will give you a concole login

prompt. login with the “user2” which was added. you can even change root’s

password from there and get root access.

unmount filesystem and reboot. if all went OK, you should get a console
login prompt instead of booting into the very limited GUI. now you
should be able to login whith “user2” and the same pasword “user” has.
you have root privilages. you could even punch in “startx” and xfce
desktop should appear, whith full functionality. NOTE: I am not a linux
expert, this is a nasty way of getting in, but it worked for me. If,
however, things do go wrong, reset/reboot, press “u” and choose option 2
ate the system resume menu. then your system should be restored to
factory defaults.use this info at your own risk, I just shared this for
interesting sake. I have searched all over and could not find any info
reagdring this, so here is something. use is, dont use. up to you.

there could be much more added to this, to finalise it, to finish off the rough edges…

Ja, I saw that, but thought a Linux guru could help out here.

Agggg, not a biggie. Will play around with it when I have the time and see if I can find the hidden keypress to enter its BIOS…

Figured out how to upgrade the installed Jaunty (Ubuntu) version to Karmic, but it does not play ball after the upgrade is finished.

Will see if I can upgrade to a higher version… if it fails as well, then I’ll just leave it as is for the ooklets to play with.

Upgrade meh shmeh

Resetted it to factory defaults and gave it to ooklets to play around with, not worth the hassle and all that.