Had a bit of downtime today, sorry

Not sure exactly what happened, but had about a ~2 hr outage today, probably because of something I did.

Longer version for people who want more juicy details: Discourse runs in a Docker image, which is sort of like a virtual machine, but very much stripped down—rather than a whole operating system, a docker image works a lot like a BSD chroot jail, with just the things you package into it running independently and using your real OS for the rest. This has its good and bad points. The good is that it eliminates a lot of configuration variability, since the two databases (redis and postgresql) used by Discourse are contained inside the docker image, along with all the Ruby config garbage and the unicorn processes and everything else. The bad points are that docker can be just maddeningly opaque when it comes to troubleshooting any problems that do come up. It’s basically a black box. When it works, it works great. When it breaks, you’re screwed.

I’m not sure entirely why, but Docker broke today, kind of out of nowhere. But the good news is that I fixed it! I’m also not entirely sure how I fixed it, but hey, here we are!

1 Like

I demand a refund!

1 Like

I demand a double refund!

:moneybag: :moneybag: YOUR CHECKS ARE IN THE MAIL :moneybag: :moneybag:


I’ll give Lee a pass here since I was out shopping with my kids at the time (spending their Christmas loot). I would’ve never known about the outage had he never mentioned it.

Hey Lee,

I don’t know if it’s related or not, but I can’t log out anymore…

1 Like

You can log in, but you can’t log out anymore… muhuhahahaha

I reported the same issue…

Why would you ever want to leave? :joy:


Ok, so, I don’t know if this is related to the downtime issue, the migration, or nothing at all, but most of the times I have tried to edit posts lately (fixing typos, mostly), it doesn’t work. I get the bar at the bottom that says “Saving” with the swirly circle, but it never finishes or applies the edit. It has now happened on different computers, and different browsers, and I think even on mobile chrome. I can’t think of any other potentially pertinent details or variables.

The internet hates you.

1 Like

TypeError: e.responseJson.post is undefined

Ooooh, I tried to edit one and it let me save it, but then showed this error.

And now it did it again, but it doesn’t do it until I try to reply again.

And I have a post that I started in this thread, canceled, but it keeps coming up. I decided to submit it as this.

You can’t. You can check out, but you can never leave.


I also have a post bookmarked and can’t un-bookmark it.

Yeah, I tried to correct my previous post but got the same problems.

For the record, what I meant to say was:

You can check out any time you like, but you can never leave.


Instead of demanding a refund, has anyone here considered a lawsuit? :stuck_out_tongue_winking_eye:


Edit : Wut? When I tried to post this post with only the above, I got this dialog box :

1 Like

I knew where you were going with it. :wink:

Yeah, seen that sort of thing before, possibly from the same comment!