3TB drives and up

3TB, 4TB and 5TB drives are now getting more and more common. But they have to be formatted a specific way in order for both Windows and Mac to recognize the full capacity. For Windows, it’s with the “GUID partition table (GPT) partitioning scheme”. If you buy it as an external drive like from Seagate, then it’s already formatted for you.

Except, I just had one stop being recognized by the Win 7 computer for a while. I thought the drive had died from when the USB interface that was in the bottom of the drive case came loose. Crack open the case, plug in a different USB interface and then it kinda starts showing up as an unformatted drive. Then as a 750GB drive. Then as a pair of about 375GB drives. Then all of a sudden, it’s back to working completely and showing the full 2.72TB and the files I had on it.

From what I can see, having them show up as 750GB drives is common because that’s the leftover amount from when the OS stops recognizing the drive size. There’s quite a few messages about people trying to follow the directions on formatting it correctly and setting the partition correctly and still not being able to get it to work. I did too on the first 3TB drive I bought to replace a drive that was acting like it was going to die. Took it back and exchanged it for a 2TB drive.

And now with this formerly external 3TB drive which is now sans case and will be used as an internal drive, I don’t want to have to keep fussing with trying to figure out what will make Windows happy and deign to format the silly thing. Can I just tell it to give me two partitions so that one of them is less than 2TB and whatever’s left over is in the other partition? If I can do that, I’d rather have two reliable partitions than one big partition.

I had some similar experiences with a Seagate drive, back when Windows would only recognize a high-capacity drive if a certain service pack was installed (I think that was Windows XP service pack 3, but it was years ago).

In that case, formatting the drive into separate logical partitions didn’t work, because Windows would still have to be able to see all of the space available - which it couldn’t do. In fact, I ruined two of the drives by attempting to format them (Seagate was nice enough to replace them).


Anyone know if Windows 10 addresses this problem?

You can also run into issues if you move the drive to a different controller, or the same controller with different drivers. We saw that show up at work a few years ago. Someone upgraded the Intel storage driver on several workstations, then they wouldn’t see the drives that had been setup on the workstations with the old drivers, and vice versa. As a bonus, neither set of drives worked right when we popped them into a USB dock, but worked ok via eSATA on the workstations where they worked internally. We found the USB issue when we were trying to migrate the data before upgrading all the Intel drivers to the latest version, which also fixed an issue of drives “disappearing”.

I think I’m going to keep this simple. Until they are no longer available for sale, the largest hard drive I’m going to buy is a 2TB drive. That should keep me going for quite a few more years and I don’t have to worry about whether I plug it into the same USB port or use the same USB adapter or anything else that makes these things so problematic.

I’m going to take that advice as well. I had enough of a headache when I discovered my brand-new USB hub wasn’t 3.0.

Speaking of which, I caution everyone regarding buying anything USB from Amazon, because quite a few sellers aren’t specifying whether it’s 2.0 or 3.0.

Been there, gone through that.

Had some 3TB drives that my USB drive-dock thing would only see as ~800GB. Upgraded the dock to a newer model and the drive worked perfectly.

Seems to be a re-occurance of the (ancient) issues with drive sizes go over a 2^X size. Same as when 512MB drives came out, then 2GB drives, and so on.

CWX: that one you were talking about is hard drives larger than 137GB in size. I think you had to add a Registry key that was something like “EnableBigLBA”.

Really? I was told Windows wouldn’t handle it without the right service pack.

If my memory is correct, WinXP 32bit will not address a HDD larger than 2TB, but x64 will.

I didn’t see a better thread to post this on, and I didn’t want to start a new one. Blame it on my necrophilia.

So, are SSDs as vulnerable to magnets as the old HDs?

And yes, this is important research. It may become a plot point in something I am working on.

I don’t think even HDDs have had issues with vaguely normal magnets for a long time now. They’ve got damn powerful magnets inside the case after all. I don’t see SSDs having an issue with a relatively stable magnetic field either.

Now, if you’re looking at using that field to induce current, that changes things. But it’s been too long since I’ve done enough of that to have any clue as to how powerful a field you’ll need to physically harm electronics (beyond “not small”).

I was thinking something along the lines of a handheld bulk tape eraser.

I’m not sure whether the electrical potential would be more damaging than the magnetic potential with a tape eraser (assuming it’s one of the mains powered ones that the local TV station uses).

Part of getting my Win 7 system ready to fix the motherboard issue I’m having included making another backup. So I went out and bought a 6TB drive, forgetting two things:

  1. The issue I described above about how I was having problems with drives larger than 2TB.
  2. The fact that I had previously bought an external 5TB drive.

Well, it worked for a while. I got everything copied over to the new drive. All that was left is to look into application settings, passwords, program licenses and so forth.

Now the drive doesn’t work any more. Win 7 sees the unit but not the partitions and won’t even show it in Device Management. If I plug it into the work laptop that’s running Win 10, it’s fine.

After digging into this some more, I think the biggest problems I was having is there have been no BIOS updates for my motherboard since 2013 and the adapters I have to plug hard drives into are older USB 2.0 adapters. It doesn’t really explain why the external 6TB unit worked for the day it was plugged in while I made the backup, but not after being plugged back in later. It’s a USB 3.0 device being plugged into a USB 3.0 port.

At some point, I’ll get around to building a Linux file server on a much newer motherboard and put some big drives into that. For now, I’m back to getting files copied from the current 2TB drive that may or may not be failing onto a new 2TB drive I had bought a couple of months ago.

Threaddus Resurrectus.

The same 3TB drive that prompted this topic was used for quite a while after it settled down and I was able to copy the data onto my NAS. As part of upcoming restructuring of the NAS, I started comparing what was on the NAS to the original drives so I could free up space on the NAS.

The drive is back to misbehaving. Windows thinks it has a 349.31GB partition and two unallocated sections of 1698.69 GB and 746.52 GB. It wants to format the first one.

Fussy years ago, works reliably for a long time, then fussy again in the same kind of way. That’s too big of a coincidence.

It’s a Seagate ST3000DM001. Seagate uses this format for the date: YYWWD. YY for the year, WW for the number of the week in the year, and day. 13031 for mine, so it was made in the 3rd week of 2013 on a Saturday because Seagate goes by a Saturday to Friday calendar.

So a search for that model number and what do you get? An article about a class action lawsuit, Backblaze’s article on how a third of the drives they deployed failed in under three years, and an article providing a counterpoint to Backblaze’s article, saying they were using consumer-grade drives in a NAS environment, their custom-made chassis often used rubber bands to “reduce the vibration” and this model of drive doesn’t include an RV sensor (rotational vibration). Digging further, another site attributed the failures to a difference in materials used for the parking ramp inside the drive.

The end result is Backblaze may have inadvertently set themselves up for this higher number of failures. They had to react when the 2011 floods in Thailand damaged factories that make ~50% of the world’s hard drives and drive prices jumped 300% overnight. Their business uses dozens of drives every day as they add capacity, so they began making runs to Costco and other stores to get what they could. It’s an interesting tale, including how they ended up getting banned from Costco because of how many they were trying to buy.

All of that sounds like this model of drive had mechanical issues. The “how many partitions do I have” issue sounds like a logic problem. Maybe the controller on the drive just decides whether it will play nice or nasty when it boots, or maybe it’s something in Windows, but two different computer with different versions of Windows experiencing the same problem with this one drive makes it less likely to be a Windows issue. Seagate’s website says the drive has the newest BIOS.

Because I got everything from it over to the NAS before it had another mood swing, it should be okay to decommission the drive with a five pound sledgehammer. I’ll know shortly what data came from the drive and make sure it’s recopied onto a spare.